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Serraview Core API Troubleshooting

The following troubleshooting articles will help you diagnose and solve problems.

Error Description

Error - Requesting Result

Client cannot obtain the access token, with endless requests.

2018-10-04:17:18:03.1231666: SerraView subsystem interface is starting...
2018-10-04:17:18:03.1387910: Generating Json Web Token. . . .
2018-10-04:17:18:03.2012925: Generating Json Web Token Successful. . . .
2018-10-04:17:18:03.2169172: getAccessToken(), Generating Access Token. . ., Attempt: 1
2018-10-04:17:18:03.2325420: getAccessToken(), Requesting Result. . . .
2018-10-04:17:18:03.6075474: getAccessToken(), Response Status : NotFound
2018-10-04:17:18:03.6075474: getAccessToken(), Generating Access Token. . ., Attempt: 2
2018-10-04:17:18:03.6075474: getAccessToken(), Requesting Result. . . .
2018-10-04:17:18:03.7325496: getAccessToken(), Response Status : NotFound
2018-10-04:17:18:03.7325496: getAccessToken(), Generating Access Token. . ., Attempt: 3
2018-10-04:17:18:03.7325496: getAccessToken(), Requesting Result. . .

Cause

OAuth is not enabled.

Resolution

Contact Serraview Support to enable OAuth.

Error 404

2018-11-06 15:36:32 [INFO] - MainThread:  Starting new HTTPS connection (1): linkedin.uat.serraview.com
2018-11-06 15:36:33 [DEBUG] - MainThread:  "POST /oauth2/token HTTP/1.1" 404 67493

Cause

OAuth is not enabled.

Resolution

Contact Serraview Support to enable OAuth.

Error 302

The Client uses the Robot User with password identification to unlock a report API but it is producing Error 302- URL directional error and the API Robot User is currently locked in security. We were able to unlock it. Can you please look into Error 302- URL directional error and find out why the account was locked? 

Response code: 302
<html><head><title>Object moved</title></head><body>
Object moved to here.

Cause

Incorrect login credentials for API user account.

Resolution

  1. Check login credentials on the client-side.
  2. Reset password if required.

Error 401

401 - 'Unauthorized' 

Causes

  • User does not have the required secured actions required.
  • Issue with obtaining access token (client side).
  • Transactions longer than 20 mins will time out.

Resolution

  1. Navigate to Admin > User Security.
  2. Make sure the the User Account has the correct role.
  3. Make sure the Role has the correct secured actions - this includes API access and the report secured actions.

For more details, refer to Manage User Roles

Error 403

Cause

User has failed to include the scope attribute in the JWT, this causes the user to have insufficient permissions.

Resolution

  • Ask the user to include the 'scope' attribute in the JWT.

Error 511

511 - Network Authentication Required

Causes

  • There's no Service Account, or Account credentials are incorrect (wrong password etc).
  • The Service Account does not have the correct role/secured actions assigned.

Resolution

We recommended that you keep all Service Accounts in PROD so they can be copied into UAT.

For more information access, refer to Access Serraview APIs.